Prerequisites


1.  Download Idea Pro developer bundle.

 

2.  Following are the software requirements need to install the ideamart simulator.

 

  • Java version 1.6.0 or upper

 

– Install Java in Windows

http://java.com/en/download/help/windows_manual_download.xml

 

– Install Java in Linux

http://www.java.com/en/download/help/linux_install.xml

 

3.  Following are some tools which will help you to develop apps.

 

IDEs

– Netbeans

https://netbeans.org/downloads/

– Eclipse

https://www.eclipse.org/downloads/

– IntelliJ IDEA

https://www.jetbrains.com/idea/download/

 

Web Servers

– XAMPP

https://www.apachefriends.org/download.html

– WAMP

http://www.wampserver.com/en/

 

Connectivity Tools

– WinSCP

http://winscp.net/eng/download.php